Skip to end of metadata
Go to start of metadata

New!

We are experimenting with a set of scripts that automate prerequisite installation. This should greatly simplify the process of building LTR prerequisites on new computing environments. Find the script & patches here:

Don't see your environment listed? Contact us or follow the directions below to manually build everything.

Prerequisites

The LFM requires supporting software in order to function properly. Before building these prerequisites, we recommend you set a few environment variables:

Variable

Description

CC

path to C compiler (ie. icc, pgcc, xlc, etc.)

CXX

path to C++ compiler (ie. icpc, pgCC, xlC, etc.)

F90

path to Fortran 90 compiler (ie. ifort, pgf90, xlf, etc.)

FC

Set to ${F90}

F77

Set to ${F90}

MPICC

path to MPI C compiler (ie. mpicc, mpcc, etc.)

MPICXX

path to MPI C++ compiler (ie. mpiCC, mpicxx, etc.)

MPIF90

path to MPI Fortran 90 compiler (ie. mpif90)

INSTALL_DIR

Path where you will install all the prerequisites.  If you do not have root access, we recommend you make a directory in your $HOME named according to the compiler combination you're using.  For example, using version 11.1 of the Intel compilers and version 1.4.4 of OpenMPI:

mkdir ~/opt-intel-11.1-openmpi-1.4.4
 export INSTALL_DIR=$HOME/opt-intel-11.1-openmpi-1.4.4


We have found the best performance with the Intel compiler suite versions 9, 11 and 12.

We have tested the LFM with the following versions of the prerequisites:

MPI

  • We recommend OpenMPI and have had luck with version 1.4.x.
  • Please make sure that the MPI on your system was built with the same set of compilers you wish to build the LTR with. For example, if you are using the Intel compiler suite, make sure mpicc --version corresponds to the Intel C compiler.

A++ & P++

InterComm-2.0

Overture

  • No labels