Blog
Skip to end of metadata
Go to start of metadata

The serial card problem is a bit mystifying. It didn't happen in CHATS, and we had about the same or more load on the data system.

Systems with the Emerald 8P cards seem to be the ones that are failing. I don't believe we had those at CHATS.  So I'm removing them from our systems.

upwind: had 1 8P card and 1 8M. It was only using 7 ports on the 8P and none on the 8M, so I removed the 8P and cabled the 8M as the first and only card.  There is still an available port for the 15th pressure system.

downwind2: removed 8P W274177, installed 8M W240036, which is a spare card.  This board has a dead port #1 (numbered from 0) which is /dev/ttyS6 when it is installed as the first card.  To minimize the cabling changes. I installed W240036 as the second card, and so W249924 is now the first card. This means that port /dev/ttyS14 is now dead, and the last sonic was switched to /dev/ttyS15.

Currently the profile tower has the only remaining 8P card (and it has been working quite well since we improved the voltage level).

Later noticed that port ttyS7 on upwind was not working. Seems that W240025 also has a bad port.  Since we want all ports to work on upwind in order to have one available for the 15 pressure system, I did another swap on Jul 8. At 10:20am removed the first emerald card, W249924, from downwind2, installed it on upwind. Took W240025 from upwind and installed it as the first serial board on downwind2.

The data system configuration is now:

name

viper#

box

tower

net link

serial #0

serial #1

profile

3

6

profile

eantg

8P W274095

8M 240017

downwind1

6

14

d4

hub in profile

8M W249918

8M 250043

downwind2

1

13

d10

eanth

8M W240025

8M W240036

upwind

2

1

u7

hub in downwind2

8M W249924 

 

pressure1

10

small

d4

hub in profile

 

 

pressure2

11

large

d10

hub in downwind2

 

 

These serial cards have bad ports

SN

bad ports

W240025

2(ttyS7)

W240036

1(ttyS6)

 W240025 and W240036 are on downwind2. The configuration on downwind2 skips ports ttyS7 and ttyS14.